Aporte: Scripts y rutinas útiles para automatizar procesos en Mikrotik

Tema en 'Manuales Mikrotik Varios' iniciado por Andres, 12 Sep 2010.

  1. Andres

    Andres Fundador VSC Moderador

    Me Gusta recibidos:
    38
    Aporte: Scripts y rutinas útiles para automatizar procesos en Mikrotik

    Scripts y rutinas útiles para automatizar procesos en Mikrotik


    [​IMG]

    Muchos se preguntaran que son los Scripts en Mikrotik?.. pero sencillamente son algunas rutinas que automatizan los procesos, es decir hacen las cosas automaticamente por nosotros siempre y cuando le asignemos una fecha y hora.

    Pueden copiar y pegar directamente en la consolo. Si les da error copien y peguen en el Block de Notas yy de ahi loos acomodan y lo pengan a la consola. Sino lean la instruccion y la hacen manualmente. Todos estos Script funcionan, ti tienen Mikrotik *** PALABRA EDITADA POR EL ADMINISTRADOR *** Lastima, existe la posibilidad de que no les funcione.


    Todos los SCRIPTS deben ser insertados via "WINBOX" en el menu "SYSTEM" submenu "SCRIPTS" o bien via "NEW TERMINAL" /system script

    NOTA: Estos son los scrips, mas adelante estan los Sheduler que son los que haran que el script se ejecute automaticamente.



    SCRIPT PARA REINICIAR AUTOMATICAMENTE

    CODE, HTML o PHP Insertado:
    add name="reiniciar" source="/system reboot" policy=ftp,reboot,read,write,policy,test,winbox,password

    SCRIPT PARA DETENER LA WEB-CACHE

    CODE, HTML o PHP Insertado:
    add name="detener_proxy" source="/ip web-proxy set enabled=no" policy=ftp,reboot,read,write,policy,test,winbox,password

    SCRIPT PARA LIMPIAR WEB-CACHE


    CODE, HTML o PHP Insertado:
    add name="Limpiar_Proxy" source="/ip web-proxy clear-cache" policy=ftp,reboot,read,write,policy,test,winbox,password

    SCRIPT PARA REINICIALIZAR LA WEB-CACHE

    CODE, HTML o PHP Insertado:
    add name="Crear_Proxy" source="/ip web-proxy set enabled=yes" policy=ftp,reboot,read,write,policy,test,winbox,password

    SCRIPT PARA BACKUP AUTOMÁTICO DEL MIKROTIK


    CODE, HTML o PHP Insertado:
    add name="respaldo_diario" source="/sy ba sav name=mk_bkp.backup" policy=ftp,reboot,read,write,policy,test,winbox,password


    RUTINAS UTILES


    Deben ser aplicadas via Winbox; Menu "SYSTEM", submenu "SCHEDULER" o bien via "NEW TERMINAL" en /system scheduler


    Programar reinicios de 15 en 15 dias


    CODE, HTML o PHP Insertado:
    add name="reiniciar" on-event=reboot start-date=aug/15/2008 start-time=06:05:00 interval=2w1d comment="REINICIO CADA 15 DIAS" disabled=no

    Programar el mantenimiento automatico del WEB PROXY (Cada 5 dias)

    CODE, HTML o PHP Insertado:
    add name="detener_proxy" on-event=detener_proxy start-date=Aug/15/2008 start-time=05:00:00 interval=5d comment="Detener Proxy para mantenimiento" disabled=no

    CODE, HTML o PHP Insertado:
    add name="Limpiar_Proxy" on-event=Limpiar_Proxy start-date=Aug/15/2008 start-time=05:03:00 interval=5d comment="" disabled=no

    CODE, HTML o PHP Insertado:
    add name="Crear_Proxy" on-event=Crear_Proxy start-date=Aug/15/2008 start-time=05:10:00 interval=5d comment="Mantenimiento automatico del Web-Proxy" disabled=no

    Programar el respaldo automatico cada 6 horas


    CODE, HTML o PHP Insertado:
    add name="respaldo_diario" on-event=respaldo_diario start-date=Aug/16/2008 start-time=00:00:01 interval=6h comment="Crear respaldos cada 6 horas" disabled=no
     
  2. futuroelectron

    futuroelectron New Member

    Me Gusta recibidos:
    0
    Muchas gracias amigo, con estas rutinas de mantenimiento nos quitamos parte el dolor de cabeza jejeje [​IMG]

    Apenas estoy iniciando en este mundo de Mikrotik, me parece sumamente provechoso, ya que el nivel de optimización que le podemos brindar a nuestras redes con esta herramienta es impresionante!!!

    Saludos!
     
  3. krbi

    krbi New Member

    Me Gusta recibidos:
    0
    hola amigo, tendras un script para hacer mantenimiento a THUNDERCACHE de borrar algunos archivos que no hicieron HIT digamos en 15 o 20 dias, al THUNDERCACHE lo tengo con OS MIKROTIK..
     
  4. josnan

    josnan New Member

    Me Gusta recibidos:
    0
    Buen dia Andres, muy buena labor ayudando a "culturizar" a nosotros los neofitos en estos campos. Se pueden establecer un horario para liberar restricciones de descarga, por ejemplo de 21:00 a 05:59 eliminar bloqueo o restricciones de p2p o descargas directas
     
  5. soyjesa

    soyjesa New Member

    Me Gusta recibidos:
    0
    saludos amigos, tendras uno para avisarles a los clientes por pppoe o hospot que estan cortados. ??? gracias
     
  6. zone-net

    zone-net New Member

    Me Gusta recibidos:
    0
    Saludos Andres, el script para detener el web cahe tambien se puede hacer desabilitando la regla de redireccionamiento en nat, digo esto para que los amigos sepan buscar alternativas y no solo copiar; hay muchas formas de hacer lo mismo, la cosa es entrenarnos los invito a probar la practica nos convertira en maestros.

    Krbi,como es eso de que tienes el thundercache en OS mikrotik ?.

    Para borrar los archivos que estan demas en el thunder hay que crear un sh copia este codigo creando un archivo dentro de tu server y ejecutalo cuando desees borrar.#!/bin/sh
    data=`date +"%Y-%m-%d" -d "17 week ago"`

    dirs=`find /thunder/ -name domain.db`

    for d in $dirs
    do
     
  7. serteinvica

    serteinvica New Member

    Me Gusta recibidos:
    0
    Buenas Tardes,

    Amigo estoy en busca de un scrip que me renueve automaticamente cada cierto tiempo la interface wan, dhcp cliente ya que aveces me quedo sin internet y tengo que ir manualmente a renovar la direcion ip espero algun aporte de su parte..
     
  8. edwardxp

    edwardxp New Member

    Me Gusta recibidos:
    0
    Amigo estoy en busca de un scrip que me renueve automaticamente cada cierto tiempo la interface wan, dhcp cliente ya que aveces me quedo sin internet y tengo que ir manualmente a renovar la direcion ip espero algun aporte de su parte..
     
  9. Jorge-Coronel-WiFi

    Jorge-Coronel-WiFi New Member

    Me Gusta recibidos:
    0
    no abra un script para que la pc encienta sola por que siempre se me va la electrisidad y tengo que ir a prenderla cuando yega
     
  10. caycara2000

    caycara2000 Fundador VSC Moderador

    Me Gusta recibidos:
    55
  11. caycara2000

    caycara2000 Fundador VSC Moderador

    Me Gusta recibidos:
    55
    En la BIOS dentro de la pestaña Advanced tienes una opción que se llama "Restore on AC/Power Loss", por defecto viene en OFF, unicamente debe ponerla en ON.
     
  12. elizerdiaz

    elizerdiaz New Member

    Me Gusta recibidos:
    0
    scrip que renueva una interface wan

    Viejo vamos a ver si te sirve este, lo uso en mi balanceador para no estar pendiente de cual linea esta inactiva..

    -primero el script que se va a ejecutar:
    /system script
    add name=script1 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=
     
  13. tonyvzla

    tonyvzla Member

    Me Gusta recibidos:
    0
     
  14. Drreck

    Drreck New Member

    Me Gusta recibidos:
    0
    Hola q tal buen dia!

    Estoy tratando d automatizar mi hot spot hay alguna forma de agregar usuarios automaticamente, como puedo generar usuarios y agregarlos automaticamente, trabajo en un proyecto te cuento rapidamente diseño una maquina vending para el control de acceso a un hot spot pero no se como automatizar la parte en donde se generen nombres de usuarios yse den de alta, en un puerot usb tengo el estado de activado cuando han pagado pero como puedo ahcer q cuando ese estado este activo se agregue un usuario acutomaticamente, podrias recomendarme algo de lectura o algo para poder darle solucion a esto? nos puede beneficiar a muchos usuarios incluso comparto el diseño solo hechenme la mano con este problemilla q no logro desenmarañar...
     
  15. josedan

    josedan New Member

    Me Gusta recibidos:
    0
    Bueno mi pregunta es la siguiente:

    Resulta que tengo configurado mi hotspot en una motherboard rb433 , y me eh comprado un router mikrotik 750gl , mi gran duda es si tengo que limpiar toooda la configuracion de mi rb 433 y empezar de nuevo con el 750 gl o agregar alguna ruta al nuevo router que hacer por favor ya que poniendo la 433 al 750gl no me funciona no resuelve dns me parece SOY NOVATO alguna ayuda por favor
     
  16. juanwifi

    juanwifi New Member

    Me Gusta recibidos:
    0
    lo que espera y quiero uno que me ejecute un backup guardoado en el mikrotik todos los dias a sierta hora para su mantencion
     
  17. caycara2000

    caycara2000 Fundador VSC Moderador

    Me Gusta recibidos:
    55
    Osea para que se mantega sin problemas, pero la cosa se complica cuando agregues sus clientes, y cual seria la idea practica de montar un backup ya guardado, el este caso es para evitar que despues de guardar en tu pc el backup de ayer por ejemplo y en 3 dias tu Mk se colapso y no encutras la solucion hacer un Restar y colocar el guardado y tienes nuevamente tu mk operativo. [​IMG]
     
  18. jeancops22

    jeancops22 New Member

    Me Gusta recibidos:
    0
    buenas algun scrip para borrar cada cierto tiempo los cookies del mikrotik
     
  19. caycara2000

    caycara2000 Fundador VSC Moderador

    Me Gusta recibidos:
    55
    Puedes hacerlo tu mismo, es la misma idea como los demas un SCHEDULER y un script, pero en este caso como lo puedes hacer, entra a new terminal y teclea donde quieres hacer el cambio, ip hotspot cookies remove, si de esta manera se eliminan, entonces eso es lo que va en el script. [​IMG]
     
  20. jeancops22

    jeancops22 New Member

    Me Gusta recibidos:
    0
    mmm digamos que lo hice pero la idea es automatizar ese procesopor decir cada 30 min que se borren solo
     

Compartir esta página