configurar mikrotik con proxycache sin bloquear los juegos OnLine

Tema en 'MikroTik Avanzado' iniciado por chatiando, 20 Oct 2016.

  1. chatiando

    chatiando Member

    Me Gusta recibidos:
    3
    bueno el titulo lo dice todo
    configurar mikrotik con proxycache sin bloquear los juegos OnLine

    actualmente tengo un mikrotik para control de ancho de banda, firewall etc. pero desde ayer
    estoy partiendome la cabeza con esta funcion del proxycache transparente que la quisiera activar
    pero en lo que la activo los usuarios se quejan que no pueden acceder a sus juegos online.

    no encuentro el modo de que todos los juegos variados que la gente les gusta se salten el proxy pero solo los juegos online.

    ejemplo candycrusch , etc.
    cuando el proxy esta apagado todo bien pero si vuelvo a activar ese proxy dejan de conectar a juegos.


    aca les dejo lo que implemente para proxycache transparente



    /queue type
    set 0 kind=pfifo name=default pfifo-limit=50
    set 1 kind=pfifo name=ethernet-default pfifo-limit=50
    set 2 kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
    set 3 kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 \
    red-limit=60 red-max-threshold=50 red-min-threshold=10
    set 4 kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
    add kind=pcq name=PCQ_download pcq-burst-rate=0 pcq-burst-threshold=0 \
    pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \
    pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=250k \
    pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000
    add kind=pcq name=PCQ_upload pcq-burst-rate=0 pcq-burst-threshold=0 \
    pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \
    pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=100k \
    pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000
    add kind=pcq name=PCQ_DOWNilimiado pcq-burst-rate=0 pcq-burst-threshold=0 \
    pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \
    pcq-dst-address6-mask=128 pcq-limit=500 pcq-rate=1600k \
    pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000
    add kind=pcq name=PCQ_UPilimitado pcq-burst-rate=0 pcq-burst-threshold=0 \
    pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \
    pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=700k \
    pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000
    add kind=pcq name=pcq-up pcq-burst-rate=0 pcq-burst-threshold=0 \
    pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \
    pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 \
    pcq-src-address6-mask=128 pcq-total-limit=2000
    add kind=pcq name=pcq-down pcq-burst-rate=0 pcq-burst-threshold=0 \
    pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \
    pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 \
    pcq-src-address6-mask=128 pcq-total-limit=2000
    set 11 kind=none name=only-hardware-queue
    set 12 kind=mq-pfifo mq-pfifo-limit=50 name=multi-queue-ethernet-default
    set 13 kind=pfifo name=default-small pfifo-limit=10

    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=yes interface=all limit-at=0/0 max-limit=0/0 name=queue2 \
    packet-marks="" parent=none priority=8 queue=\
    PCQ_UPilimitado/PCQ_DOWNilimiado target-addresses=192.168.0.2/32 \
    total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=yes interface=all limit-at=0/0 max-limit=0/0 name=queue1 \
    packet-marks="" parent=none priority=8 queue=PCQ_upload/PCQ_download \
    target-addresses=192.168.0.0/24 total-queue=default-small
    add burst-limit=150k/600k burst-threshold=130k/550k burst-time=5s/5s \
    direction=both disabled=no interface=all limit-at=0/0 max-limit=128k/512k \
    name=probook_neida packet-marks="" parent=none priority=8 queue=\
    pcq-up/pcq-down target-addresses=192.168.0.99/32 total-queue=default
    add burst-limit=150k/600k burst-threshold=130k/550k burst-time=2s/2s \
    direction=both disabled=no interface=all limit-at=0/0 max-limit=128k/512k \
    name="android 1" packet-marks="" parent=none priority=8 queue=\
    default-small/default-small target-addresses=192.168.0.249/32 \
    total-queue=default-small

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 \
    max-limit=0 name=queue1 packet-mark=client_download parent=global-in \
    priority=8 queue=PCQ_download
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 \
    max-limit=0 name=queue2 packet-mark=client_upload parent=global-out \
    priority=8 queue=PCQ_upload
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 \
    max-limit=0 name=queue3 packet-mark=ilimitado_download parent=global-in \
    priority=2 queue=PCQ_DOWNilimiado
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 \
    max-limit=0 name=queue4 packet-mark=ilimitado_upload parent=global-out \
    priority=2 queue=PCQ_UPilimitado

    /ip firewall mangle
    add action=mark-packet chain=prerouting disabled=yes in-interface=LAN \
    new-packet-mark=client_upload passthrough=yes
    add action=mark-packet chain=prerouting disabled=yes in-interface=WAN \
    new-packet-mark=client_download passthrough=yes
    add action=mark-packet chain=prerouting disabled=yes dst-address=192.168.0.2 \
    new-packet-mark=ilimitado_download passthrough=yes
    add action=mark-packet chain=prerouting disabled=yes in-interface=LAN \
    new-packet-mark=ilimitado_upload passthrough=yes src-address=192.168.0.2

    /ip firewall nat
    add action=masquerade chain=srcnat disabled=no out-interface=WAN
    add action=redirect chain=dstnat disabled=no dst-port=80 in-interface=LAN \
    protocol=tcp to-ports=3128

    /ip proxy
    set always-from-cache=yes cache-administrator=arlingustavo@gmail.com \
    cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=1d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=\
    no src-address=0.0.0.0

    /ip proxy access
    add action=deny disabled=yes dst-host=www.facebook.com dst-port=""
    add action=deny disabled=no dst-port="" path=*.flv
    add action=deny disabled=no dst-port="" path=*.avi
    add action=deny disabled=no dst-port="" path=*.mp4
    add action=deny disabled=no dst-port="" path=*.mp3
    add action=deny disabled=no dst-port="" path=*.zip
    add action=deny disabled=no dst-port="" path=*.rar


    /queue interface
    set LAN queue=ethernet-default
    set WAN queue=ethernet-default
     
  2. milano1

    milano1 Member

    Me Gusta recibidos:
    21
    te recomiendo que uses un proxy squid transparente en paralelo a mikrotik, o algun otro que te guste aca te dejo dos link para que escojas cual te conviene eso si debes utilizar un pc aparte para el proxy el que tiene mikrotik incorporado no me gusta para nada
    link1
    link2
     

Compartir esta página