"Ayuda" Para Balancear 2 Lineas Cantv .!

Tema en 'MikroTik Avanzado' iniciado por ppeoh, 23 Mar 2016.

  1. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    amigo te tengo una solucion efectiva solo agrega un router en cualquiera de los enlaces con el rango de ip que quieras menos el que te asignan, y de allí cualquier balanceo con ip estatica te sirve seria bueno que hicieras un balanceo pcc con ping recursivo y listo, cuando tengas eso listo me avisas y te paso mi configuración que es recursiva
     
  2. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    un ejemplo de las ip que debo usar una es 192.168.10.4 y la 0tra puede ser 192.168.20.100?
     
  3. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    en el router cual quiera con tal no sea el mismo rango de los nanos, de alli el balanceo no deberia dar problemas ya que no es el mismo gateway por que toma es el del router
     
  4. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    ya coloque un router lo hize de esta forma, pero igual sigue sin dar la wan2 la wan1 es la que tiene el router y eso que le di a varios test de descarga al mismo tiempo pero no arranca..

    /ip address
    add address=192.168.6.254/24 network=192.168.6.0 broadcast=192.168.6.255 interface=Local
    add address=192.168.10.4/24 network=192.168.10.0 broadcast=192.168.10.255 interface=WAN1
    add address=192.168.30.10/24 network=192.168.30.0 broadcast=192.168.30.255 interface=WAN2

    /ip firewall mangle
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

    add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

    add chain=prerouting dst-address=192.168.10.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.30.0/24 action=accept in-interface=Local


    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

    add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
    add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2

    /ip route
    add dst-address=0.0.0.0/0 gateway=192.168.10.4 routing-mark=to_WAN1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.30.1 routing-mark=to_WAN2 check-gateway=ping


    add dst-address=0.0.0.0/0 gateway=192.168.10.2 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.30.1 distance=2 check-gateway=ping

    /ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade


    /ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=1024 servers=8.8.8.8,8.8.4.4
     
  5. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    pasame tu id y clave de team al privando para revisar
     
  6. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    Listo amigo ya logre solucionar un amigo me ayudo...
     
  7. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    ok que bien si puedes explica como soluciono pára que los que estamos en el foro y los visitantes tengan una ayuda de tu solucion
     
  8. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    voy a decirle a mi amigo que me pase el script para colocarlo pero fue usted quien me ayudo con lo de el router ya que sin el no podia hacerlo...
     
  9. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    ok amigo esta bien pero era la solución mas factible ya que hay muchos que no quieren hacer el gasto de un router adicional
     
  10. Rula Lrtz

    Rula Lrtz New Member

    Me Gusta recibidos:
    3
    Yo tengo problemas con un balanceo de 2 aba cantv, lo estoy haciendo con Ips fijas configure los modems para ello y todo bien dan internet sin problemas, el detalle esta en que estoy haciendo el balanceo tipo both adresses and ports ¨suma¨y le tengo una regla para no tener problemas con las paginas de los bancos todo bien el problema viene que luego de 40 minutos la conexion colapsa, no da internet ni puedo entrar al RB de ninguna manera tampoco tengo pin con el RB es un HAP lite, pero me e dado cuenta de que al reiniciar el acces point (tp link wa7210n) el cual tengo conectado en el puerto 4 del rb que es mi lan vuelve la conexion a la normalidad y puedo entrar al rb sin problemas lo cual supongo yo que no es el RB el que colapsa si no el access point, quien me podria ayudar en este caso? aclaro que el uso del cpu del rb rara vez supera el 3%.

    Saludos.
     
  11. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    coloca un export de tus reglas de balanceo y de que manera tienes configurado el AP tal vez este generando algun bucle que colapsa al rb
     
  12. Rula Lrtz

    Rula Lrtz New Member

    Me Gusta recibidos:
    3
    El AP esta configurado modo acces point, sin dhcp ya que el RB se encarga de eso.

    /ip address
    add address=192.168.85.1/24 interface=LAN
    add address=10.10.10.2/24 network=10.10.10.1 interface=WAN1
    add address=11.11.11.2/24 network=11.11.11.1 interface=WAN2

    /ip firewall mangle
    add action=accept chain=prerouting comment="Permitir Bancos en Balanceo de Suma" disabled=no dst-port=443,8000-9000 protocol=tcp
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=wan1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=wan2_conn
    add chain=output connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1
    add chain=output connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2
    add chain=prerouting dst-address=10.10.10.0/24 action=accept in-interface=LAN
    add chain=prerouting dst-address=11.11.11.0/24 action=accept in-interface=LAN
    add chain=prerouting dst-address-type=!local in-interface=LAN per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=wan1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=LAN per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=wan2_conn passthrough=yes
    add chain=prerouting connection-mark=wan1_conn in-interface=LAN action=mark-routing new-routing-mark=to_wan1
    add chain=prerouting connection-mark=wan2_conn in-interface=LAN action=mark-routing new-routing-mark=to_wan2

    /ip route
    add dst-address=0.0.0.0/0 gateway=10.10.10.1 routing-mark=to_wan1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=11.11.11.1 routing-mark=to_wan2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.10.10.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=11.11.11.1 distance=2 check-gateway=ping

    /ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade

    /ip pool
    add name=dhcp_pool1 ranges=192.168.85.2-192.168.85.254
    /ip dhcp-server
    add address-pool=dhcp_pool1 authoritative=after-2sec-delay bootp-support=static disabled=no interface=LAN lease-time=1d name=dhcp1
    /ip dhcp-server
    config set store-leases-disk=5m
    /ip dhcp-server network
    add address=192.168.85.0/24 gateway=192.168.85.1
    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4
     
  13. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    Por lo que veo tu reglas estan bien , fijate en tools profilafe cuanto llega lo que dice flash, yo tuve un problema parecido al tuyo y era que tenia muchas reglas que consumian la memoria flash del rb, lo deje lo mas basico y resueltu el problema
     
  14. Rula Lrtz

    Rula Lrtz New Member

    Me Gusta recibidos:
    3
    [​IMG]

    Es lo que me sale, aclaro que esto lo tengo para uso casero, solo 6 equipos conectados entre telefonos y computadoras. Saludos.
     
  15. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    me extraña que el ap te colapse el rb revisa que cantidad de ram tienes libre cuando esta a punto de colapso puede que sea eso tu rb es muy basico como el mio, perono colapsa y manejo unos 35 clientes
     
  16. Rula Lrtz

    Rula Lrtz New Member

    Me Gusta recibidos:
    3
    Ok amigo milano1, pero recuerda que es el AP que me colapsa no el RB bueno lo digo por que solo reinicio el ap y todo vuelve a la normalidad sin tocar el RB ni reiniciarlo ni nada, gracias por tu ayuda estare al pendiente. Saludos.
     
  17. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    busca en la pagina oficial de tp link a ver si hay alguna actualización y se la instalas y haces las pruebas
     
  18. Rula Lrtz

    Rula Lrtz New Member

    Me Gusta recibidos:
    3
    Oks milano estare informando cualquier cosa. Saludos y gracias por la ayuda.
     
    A milano1 le gusta esto.
  19. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    saludos vuelvo por aca amigo, el script que me hicieron funciona todo bien execto que tengo el problema con los bancos....
     
  20. milano1

    milano1 Member

    Me Gusta recibidos:
    22
    que balanceo te dieron pcc o nth con el pcc no da problemas ni con banesco ni bod
     

Compartir esta página