"Ayuda" Para Balancear 2 Lineas Cantv .!

Tema en 'MikroTik Avanzado' iniciado por ppeoh, 23 Mar 2016.

  1. ppeoh

    ppeoh New Member

    Me Gusta recibidos:
    0
    Ante todo buenos dias soy nuevo en el foro quisiera pedirles un poco de ayuda para poder saber como se balancea 2 lineas cantv.. soy del tigrito anzoategui actualmente por aca el internet esta fatal.. tengo instalado mikrotik routeros v5.20 en una pentium 3 dell de 512 de ram 1 ghz de procesador y 20 gb de disco duro.. 2 tarjetas de red y la que trae el pc serian 3.. es la primera vez que trabajo con mikrotik tengo un hotspot instalado y tengo varios usuarios.. tengo una linea de 1 mb y la otra de 3 mb.. queria aumentar la velocidad pero sinceramente la cantv es una basura y eso es un proceso conozco de una persona que cambio de plan y ahora le corre peor el Internet instalo el de 10 mb y corre pésimo ni siquiera le da el 30 % de la conexión.. entonces quiero hacer el balanceo con esas 2 velocidades.. sinceramente necesito su ayuda...
     
  2. Ramon Bastardo

    Ramon Bastardo New Member

    Me Gusta recibidos:
    1
    Hola lo primero que debes considerar es que Mikrotik no balancea las cargas como otros dispositivos sino mas bien distribuye las conexiones de las pc de tu red entre las salidas que tengas a internet, como tienes cargas diferentes te recomiendo además de leer ver el siguiente video que en mi caso fue de mucha utilidad...

     
    A peka38 le gusta esto.
  3. caycara2000

    caycara2000 Fundador VSC Moderador

    Me Gusta recibidos:
    44
    El problema no es balancear las lineas, debes tener en cuenta de deben estar en equipos diferentes. El mk balanceador y otro como servidor con el hotstop.
     
  4. Ramon Bastardo

    Ramon Bastardo New Member

    Me Gusta recibidos:
    1
    Hola caycara2000 me llama la atención lo que comentas soy relativamente nuevo con Mikrotik y no es la primera vez que oigo o leo que deben montarse dos mk, uno para el balanceo y otro para las demas tareas.

    Pregunto: ¿esto se debe a que los routerboard no tenen una arquitectura de hardware tan robusta o se debe a alguan limitación funcional del routeros? me inclino por la arquitectura del hardware pero tengo esa duda
     
  5. caycara2000

    caycara2000 Fundador VSC Moderador

    Me Gusta recibidos:
    44
    La potencia de cada equipo es uno de los factores en el caso de que funciones como servidor pero con el balanceo adicional exigira un poco mas. Para el uso de servidor y balanceo si se puede pero no es tan facil, ya que algunas de las reglas de balanceo se afectan el funcionamiento de por ejemplo el uso de hotspot, tambien las reglas del firewall.
     
  6. Ramon Bastardo

    Ramon Bastardo New Member

    Me Gusta recibidos:
    1
    Caycara200 te consulto algo... tengo un RB2011UiAS-2HnD y con el tengo un balance de cargas de diferentes velocidades son tres en cuestión:
    1. Metro Ethernet de CANTV con IP fija
    2. ABA de CANTV con IP dinámica (obviamente)
    3. Satelca, este me sirve de enlace tambien para conectar con otras sedes con protocolo PPTP
    En un instante me funcionaron los balanceos perfectamente pero luego al ir metiendo reglas de ruteo para los enlaces solo tengo salida por el ABA y en el log tengo muchas colisiones en el ABA. ¿Que crees pueda estar ocasionando la caida en las otras conexiones de internet? los enlaces estan activos y ffuncionan muy bien.

    De antemano gracias...
     
  7. caycara2000

    caycara2000 Fundador VSC Moderador

    Me Gusta recibidos:
    44
    Lo mas seguro es que las reglas que has colocado estan enrutando solo para aba, ahora bien para saber cual esta molestando, debes ir deshablitando hasta que funcionen todas las lineas, es tedioso pero de otra forma tendrias que colocar otro rb para gestionar.
     
  8. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    saludos amigo caycara, pregunto tengo un cpu con routeros 5.20 tiene 3 tarjetas pci mas la integrada serian4, quiero balancear 2 wan de dos wisp diferente pero ambos tiene el servicio de cantv, ambos nano me dan las misma ip, un amigo me dice q es dificil balancear ambas xq son de cantv no se xq sera desconozco de esto, alguien que conozcas que me pueda ayudar por favor...
     
  9. milano1

    milano1 Member

    Me Gusta recibidos:
    21
    Mañana te ayudo en eso pero necesito más datos sobre las ip que usas y como te dan el Internet so es por cable o por wifi
     
  10. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    saludos amigo el internet me lo dan por wifi tengo 2 nanom2 una con un proveedor diferente, la ip de los nano son 192.168.10.2 y me pasan el internet por mac yo les pase la mac de cada nano y ellos me engancharon.. y se que la usan por cantv xq siempre q me conecto en la parte inferior de la pantalla me sale cantv y todo lo demas...
     
  11. milano1

    milano1 Member

    Me Gusta recibidos:
    21
    ok vamos a lo de las ip, que ip te entrega cada uno de los proovedores no la de los nano cuando la conectas al rb, asi te puedo dar un balanceo ya listo para usar
     
  12. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    Uno es ether1: IP address: 192.168.10.3/24 Gateway:192.168.10.2 DHCP Server:192.168.10.2 y la otra es ether3: IP address: 192.168.10.4/24 Gateway:192.168.10.2 DHCP Server:192.168.10.2 el network de las 2 es:192.168.10.0 ya tengo funcionando un script que me ayudo un amigo pero solo da internet de la wan1 la wan2 ni se inmuta...
     
  13. milano1

    milano1 Member

    Me Gusta recibidos:
    21
    ok con esa informacion me encargo mañana de pasarte una configuracion a ver si te funciona
     
  14. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    ok amigo seria de gran ayuda
     
  15. milano1

    milano1 Member

    Me Gusta recibidos:
    21
    aqui tienes un balanceo para el mismo getaway, debería ser suficiente en este LINK adaptalo a lo que necesites y listo sino me avisas
     
  16. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    este es el script que use me ayudo un amigo pero solo sale el internet de la wan1

    /ip address
    add address=192.168.10.3/24 interface=wan1
    add address=192.168.10.4/24 interface=wan2

    add address=192.168.11.1/24 interface=lan

    /ip firewall nat
    add chain=srcnat out-interface=wan1 action=masquerade
    add chain=srcnat out-interface=wan2 action=masquerade


    /ip firewall mangle
    add chain=prerouting in-interface=wan1 connection-state=new new-connection-mark=wan1_conn action=mark-connection passthrough=yes
    add chain=prerouting in-interface=wan2 connection-state=new new-connection-mark=wan2_conn action=mark-connection passthrough=yes


    add chain=output connection-mark=wan1_conn new-routing-mark=wan1_conn action=mark-routing passthrough=yes
    add chain=output connection-mark=wan2_conn new-routing-mark=wan2_conn action=mark-routing passthrough=yes


    /ip firewall mangle
    add chain=prerouting in-interface=lan connection-state=new dst-address-type=!local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=wan1_conn passthrough=yes
    add chain=prerouting in-interface=lan connection-state=new dst-address-type=!local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=wan1_conn passthrough=yes

    add chain=prerouting in-interface=lan connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1 passthrough=yes
    add chain=prerouting in-interface=lan connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2 passthrough=yes


    /ip firewall mangle
    add chain=prerouting dst-address=192.168.10.0/24 action=accept in-interface=lan
    add chain=prerouting dst-address=192.168.10.0/24 action=accept in-interface=lan


    /ip route
    add gateway=192.168.10.2 routing-mark=to_wan1 check-gateway=ping
    add gateway=192.168.10.2 routing-mark=to_wan2 check-gateway=ping

    add gateway=192.168.10.3,192.168.10.4 check-gateway=ping distance=2


    dns
    192.168.10.2
     
  17. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    este es el script que use me ayudo un amigo pero solo sale el internet de la wan1

    /ip address
    add address=192.168.10.3/24 interface=wan1
    add address=192.168.10.4/24 interface=wan2

    add address=192.168.11.1/24 interface=lan

    /ip firewall nat
    add chain=srcnat out-interface=wan1 action=masquerade
    add chain=srcnat out-interface=wan2 action=masquerade


    /ip firewall mangle
    add chain=prerouting in-interface=wan1 connection-state=new new-connection-mark=wan1_conn action=mark-connection passthrough=yes
    add chain=prerouting in-interface=wan2 connection-state=new new-connection-mark=wan2_conn action=mark-connection passthrough=yes


    add chain=output connection-mark=wan1_conn new-routing-mark=wan1_conn action=mark-routing passthrough=yes
    add chain=output connection-mark=wan2_conn new-routing-mark=wan2_conn action=mark-routing passthrough=yes


    /ip firewall mangle
    add chain=prerouting in-interface=lan connection-state=new dst-address-type=!local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=wan1_conn passthrough=yes
    add chain=prerouting in-interface=lan connection-state=new dst-address-type=!local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=wan1_conn passthrough=yes

    add chain=prerouting in-interface=lan connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1 passthrough=yes
    add chain=prerouting in-interface=lan connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2 passthrough=yes


    /ip firewall mangle
    add chain=prerouting dst-address=192.168.10.0/24 action=accept in-interface=lan
    add chain=prerouting dst-address=192.168.10.0/24 action=accept in-interface=lan


    /ip route
    add gateway=192.168.10.2 routing-mark=to_wan1 check-gateway=ping
    add gateway=192.168.10.2 routing-mark=to_wan2 check-gateway=ping

    add gateway=192.168.10.3,192.168.10.4 check-gateway=ping distance=2


    dns
    192.168.10.2
     
  18. milano1

    milano1 Member

    Me Gusta recibidos:
    21
    aqui tienes este no modifiques nada solo lo que es respecto a tus interfaces, los signos de % ni otra cosa,borra toda configuración que tengas y copia y pega esto debería funcionar recuerda que para que veas trafico en las dos wan todos los usuarios deben navegar en momentos sale por una sola wan y en otros en ambas


    / ip firewall mangle
    add chain=prerouting dst-address=192.168.10.3/24 action=accept in-interface=lan
    add chain=prerouting dst-address=192.168.10.4/24 action=accept in-interface=lan
    add chain=prerouting in-interface=wan1 connection-mark=no-mark action=mark-connection \
    new-connection-mark=wan1_conn
    add chain=prerouting in-interface=wan2 connection-mark=no-mark action=mark-connection \
    new-connection-mark=wan2_conn
    add chain=prerouting in-interface=lan connection-mark=no-mark dst-address-type=!local \
    per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=wan1_conn
    add chain=prerouting in-interface=lan connection-mark=no-mark dst-address-type=!local \
    per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=wan2_conn
    add chain=prerouting connection-mark=ISP1_conn in-interface=lan action=mark-routing \
    new-routing-mark=to_wan1
    add chain=prerouting connection-mark=ISP2_conn in-interface=lan action=mark-routing \
    new-routing-mark=to_wan2
    add chain=output connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1
    add chain=output connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2
    / ip route
    add gateway=192.168.10.2%wan1 check-gateway=arp distance=1
    add gateway=192.168.10.2%wan2 check-gateway=arp distance=2
    add gateway=192.168.10.2%wan1 routing-mark=to_wan1 check-gateway=arp
    add gateway=192.168.10.2%wan2 routing-mark=to_wan2 check-gateway=arp

    / ip firewall nat
    add chain=srcnat out-interface=wan1 action=masquerade
    add chain=srcnat out-interface=wan2 action=masquerade
     
    Última edición: 25 Oct 2016
  19. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
    voy a probar y le estare avisando amigo gracias de antemano muy amable
     
  20. Javier2012

    Javier2012 New Member

    Me Gusta recibidos:
    0
     

Compartir esta página